



	
	
		
					

			
		
					
				
				
				Skip to content

			


									
				
				
					
					
						Search
					
					
						Advanced search
					
					

				

				

			

						
			

					

				
	

		
			
				Quick links
			
			
				


					
	
								
									Unanswered topics
								
							
	
								
									Active topics
								
							
	
	
								
									Search
								
							
	


			

		
	
			
				FAQ
			
		
	
			
				Login
			
				Login
			
		
	
				
					Register
				
			



		

							Home





Board indexEnd User Forums - Current ReleasesPDF-XChange Editor	
				
					Search
				
			



	

	

	
	
	
		
		
Named Destination ISSUE . V6 of the Xchange Editor


Forum for the PDF-XChange Editor - Free and Licensed Versions



	Moderators: TrackerSupp-Daniel, Tracker Support, Paul - Tracker Supp, Vasyl-Tracker Dev Team, Chris - Tracker Supp, Sean - Tracker, Ivan - Tracker Software, Tracker Supp-Stefan







	
			
							Post Reply 
					
	
			
		
			
			
		
		
			


				
					
						Print view
					
				


		

	

	
			
			
			
				
				
					Search
				
				
					Advanced search
				
				



			

			

		

	
			
			30 posts
							• Page 1 of 1
					

		





			
		

			
				


																			

								jotagoman
							

							User
	Posts: 9
	Joined: Fri Apr 22, 2016 4:38 pm



		
						

						
						Named Destination ISSUE . V6 of the Xchange Editor
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						Post
					
								by jotagoman » Sun Jul 17, 2016 4:05 am
			

			
			
			
			Hi guys. I'am having problems using/setting the "named destination" feature. The link I create does not go where I specifically want in (it does not focus where I need it). This does not happen with a regular/direct link, the problem arises when I use the Named Destination feature in the V6 of the software (when I use V5 no problem at all).



I follow the steps to configure the focus area (rectangle size and position in the target page) but when I select "Add Current view" the created named destination does not record the desired setting (focus area). The software always enlarges/sets the view area to the full page size.



I tried many options but the result is always the same (it enlarges the view area to the full page size). The weird thing is that the issue is for Named Destination only, if I use a simple link it works smoothly.



For those who kindly want to spend some time checking this I've appended a file with instructions, see below. Please help me out.



There are four links that navigate to section 6 of the pdf:



1.	Named view using pdfx5. Works nicely. It goes to the intended focus area. And it does it without changing the setting you suggested.

2.	Named view using pdfx6 no extra zoom (only the focus area I want). This is the way it’s supposed to be but doesn’t work.

3.	Named view using pdfx6 with extra zoom. It focuses whe one wants BUT you have to zoom out to read comfortably.

4.	Simple/direct (no named view) link using pdfx6 with the focus area of interest. It works as it’s supposed to. If this works why not the named view??



From the above facts I guess that either I’m missing something when using the NAMED DESTINATIONS feature or that the Tracker-software guys need to review what's going on.



Regards.
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						Re: Named Destination ISSUE . V6 of the Xchange Editor
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								by Willy Van Nuffel » Sun Jul 17, 2016 9:34 am
			

			
			
			
			Hello jotagoman,



I have checked your example PDF.



If I understand it correctly, you have a problem with the creation of the named destination (focusing to "6 Integrity Assessment"), by using the Link Creation Tool (via Tools > Link Tools).



Myself I have tried that with PDF-XChange Editor 6.0 (build 317.1) and I do not see a problem (see attached example file - red box at the right of your own blue ones). The selected area and focus are correctly recorded. 



Are you sure to be using the most recent version of PDF-XChange Editor ?

https://www.pdf-xchange.com/product/downloads 



Best regards.
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			Thanks for your prompt response Willy. I used your file and the link you created also worked for me. 



Indeed I use the PDF-XChange Editor 6.0 (build 317.1). I do not know if my screen resolution may have something to do with it (3140 x 2860, Win 10 pro version 1511). Regardles of my screen resolution the courious thing is that when I use a simple/direct link I have no problems, when I use the Named Destination feature the focus area is not correctly recorded.



I think I'm following the right stepts to set the Named Destination. However I created a step-by-step file to make sure I'm doing it right. Can you please have a look at it and tell me if I'm missing or doing something wrong?.



Thanks.
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								by Willy Van Nuffel » Sun Jul 17, 2016 9:16 pm
			

			
			
			
			Following your instructions, I see the same behavior at my side too.



Even though, I do not think that Tracker Software had the intention to make it work in that way.



In my opinion, you must make your choice between "Use Page Number" and "Use Named Destination", and then:

- If you select "Use Page Number", you can use the parameters for the page number, x/y coordinates and the dimension of the rectangle. Then click OK.

- If you select "Use Named Destination", you have to use the vertical scroll bar to select the page and use the +/- icons (above the preview) to zoom in/out to the desired level. If you zoom in, you can drag the preview to the position that you like. At the end, you click the "Add Current View" button, give it a name, and click OK.



I must say, it does not really feel "intuitive" to me and maybe to you neither ...



Best regards.
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			This Monday morning I checked with the Link Tools feature in PDF-XChange Viewer 2.5 (Build 317.0), and it seems to work in the same way as it works in PDF-XChange Editor.



Maybe it should be better if the selection of the desired preview would work independently of whether you make a choice for "Use Page Number" or "Use Named Destination". And maybe it would also be easier if one could draw the desired selection via the preview pane... I am only making suggestions...



Best regards.
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								by jotagoman » Tue Jul 19, 2016 2:26 am
			

			
			
			
			Thanks again Willy.



I stick to the use of Named Destinations since it (page number and focus area) can be re-used several times along a document you are reading. I did what you  suggested BUT the only way I can get focus to an area at the bottom of a page is when I apply extra Zoom-in (lets say 300-400%). This extra zoom can be counterbalanced if one selects an option (edit > preferences >  view > forbid zoom changes), see attached image.



This is kind of a solution, yes (but not a complete solution for me). I remenber doing the same operation in V5 or earlier without any trouble, that's what bothers me.



The file you sent (Sun Jul 17, 2016 4:34 am) with the red rectangle link, worked correctly (appropriate focus area). Can I ask you to send a short step-by-step instruction on how you set that Named Destination (can be a list or a file with images, whatever suits you)? I just want to check if you do something that I don't.
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								by Sasha - Tracker Dev Team » Tue Jul 19, 2016 6:38 am
			

			
			
			
			Hello jotagoman and Willy,



The thing is that the Named Destination is added from the Current View on the Preview screen, meaning that it will take the left top corner of the Preview as a coordinate. Probably you've experienced the same behavior in our PDF Viewer.



Cheers,

Alex
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			Hello,



In the attachment of this post you will find the detailed instructions on how I add a "Named Destination".



I think I saw where the problem is...  It seems like the zoom-factor in the preview pane (while creating the Named Destination) is determinant for how the page will show when you click the link.



Try the following in the PDF I sent before:

(detailed step-by-step to make it understandable for every reader of this topic)

- navigate to the page where I placed the link (red rectangle)

- activate the Properties pane (via View > Other Panes > Properties pane)

- click Tools > Link Creation Tools > Link Tools

- click the red rectangle representing the link

- now, in the Properties pane, click onto "...", to edit the link (below Actions)

- click onto the name of the destination and then click Edit

- you will now see the selected area, but within the presentation of the whole page

- click Delete to delete the named destination

- without touching anything else, click "Add Current View"

- give a name to the actual view and click OK

- you will see that the selection area has changed to the whole page



This is not what one would expect.



*** I wonder what the opinion of Tracker Support would be about this ? ***



Best regards.
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			Hi Willy,



you mean the way the selected area changes to the entire page right?  It seems reasonable to me, you have deleted the existing "Named Destination" so I would also expect to lose the area it defines.



I'm just wondering, if you are deleting the named destination why you wish to keep it's boundary.  Are you just looking to rename it perhaps?



Sorry if I'm being slow Willy, I just don't understand why, if you are deleting the reference anyway, that you wish to keep the focussed area.


			
			
									
													Best regards



Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			Thanks Paul for your reply.



What I just wanted to say is that - after deleting that previous named destination - and at the moment that I am going to create a new Named Destination, I (still) see the selected area/zone in the preview of the page of the PDF.



So, I click "Add Current View" to create the named destination, I give it a name, and click OK.



I would expect that the new named destination should correspond to the selected area, but it is not so, it corresponds to the whole page.



Maybe, it should be possible to draw and select the desired zone in the preview pane and then create a new named destination that corresponds to that zone.



Thanks for reading.
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			Hi Willy,



I see your point, it would seem more intuitive to be able to use that already selected boundary.  I also like the idea of being able to drag a boundary inside that preview.



Vasyl, who would be the one to ask about this is on holidays until next week.  If I haven't posted a response to this by next Tuesday maybe bump the thread and I'll get his feedback on this?



hth
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Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
			
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																			

								Willy Van Nuffel
							

							User
	Posts: 2377
	Joined: Wed Jan 18, 2006 12:10 pm



		
						

						
						Re: Named Destination ISSUE . V6 of the Xchange Editor
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Willy Van Nuffel » Tue Jul 19, 2016 7:37 pm
			

			
			
			
			Alright for me, and I suppose for jotagoman too ...



Thanks for the consideration and discussing this with Vasyl.
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Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			Willy the instructions you sent (Tue Jul 19, 2016 4:22 am) also show the issue with the Named Destination feature. The sofware dismisses any focus area you set.



Paul, we as users welcome all the improvements you want to explore and make available to us; in fact I may have one or two to propose for handling links. One thing I want to draw attention upon tough is the fact that there is no problem when using a Direct link (not a named destination), you can select the rectangle size and its position (i.e: the focus area) and it works fine; the issue comes with Named Destinations, as per the original post and attachment (Sat Jul 16, 2016 11:05 pm)



Again I know now there is a way to work with the current issue and get what you want (Mon Jul 18, 2016 9:26 pm) which is valuable, however it would be nice if you guys gave a look at this situation.



Regards.
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			Hi jotagoman



we appreciate the feedback.  We'll do what we can here.  It will be interesting to see what Vasyl has to say next week.



[image: :-)]
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Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			Hello Paul. It'd be nice to hear from you guys.



Take care.
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			Hi jotagoman,



It's a bit early in the morning where Paul is (2.47 am to be exact), but I am sure Paul will post here as soon as he has some further comments!



Regards,

Stefan
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			One month later and still not a new word from you guys.
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			Hi, jotagoman and Willy.



In new upcoming 318 build we will fix couple annoying problems with that dialog (with creating new named destinations and others).

Also, in near future - probably in 319 build, we planning to redesign/rewrite that dialog to improve the usability significantly. 

Sorry for temporary inconveniences..



Best

Regards.
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Please archive any files posted to a ZIP, 7z or RAR file or they will be removed and not posted.
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			Hi there. Thanks for responding.



I just wanted to add a little bit more information. I found a way to handle this inconvenience though it's a 2 step procedure.



Step # 1.

Create a standard Bookmark to the target page (desired zoom, desired focus area).

You can custom the name of the bookmark if you want.

Step # 2.

Convert the Bookmark to a named destination (Main Menu: Advanced>Bookmarks>Convert to named destinations). 

And that's it. In this way the  Named destination will maintain the focus area and zoom level you want no matter what.



I hope this helps the users (though only a few seem to care or have the issue  [image: :?] ) and also help the Tracker software guys.



Looking forward to receiving the new update.
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			Hi jotagoman,



Thanks for the addtional info. - I'll forward this on to Vasyl [image: :)]



Cheers,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
			
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																			

								jotagoman
							

							User
	Posts: 9
	Joined: Fri Apr 22, 2016 4:38 pm



		
						

						
						Re: Named Destination ISSUE . V6 of the Xchange Editor
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by jotagoman » Tue Oct 11, 2016 2:11 am
			

			
			
			
			Hi there.



I was anxiously waiting the 3.18.1 build update of the V6 Xhange editor to see if this issue had been addressed. Sadly no.



Am I the only "lucky user" with the problem?



Maybe for the next update? [image: :?:]  Looking forward to hearing from the tracker team.



Bye.
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			Hello jotagoman,



I have asked Vasyl to check this once again, and we will certainly look into resolving this asap!



Cheers,

Stefan
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			Hi jotagoman.



About your old issue:


So, I click "Add Current View" to create the named destination, I give it a name, and click OK.



I would expect that the new named destination should correspond to the selected area, but it is not so, it corresponds to the whole page.


Sorry for delay.

I just checked it in 318.1 and couldn't reproduce it - it added named dest. that corresponds to the selected area (currently viewed in such dialogue, in preview control on the left).

Can you check again and confirm that?



Cheers.
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Tracker Software Products 

Project Developer



Please archive any files posted to a ZIP, 7z or RAR file or they will be removed and not posted.
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			May 2018 Editor V 7 325.1



I have just started to use the Named Destination feature. I have exactly the same problem as the first post in this list which I discovered after an afternoon of multiple tests prior to creating this post.



In Editor, although it is claimed to happen, choosing the perfect zoom and pan, creating a Named Destination and then Setting it does not store the zoom information. Changing page and then returning to the Named Destination by clicking it reverts to the default 100% non-zoom.



The only way to 'stick' the zoom/pan information is to first make a Bookmark with the appropriate view, then Convert to Named Destination, which is not a feature available in PDFExchange basic. For that I have to seemingly buy Editor Plus just to effect a work around or put up with the demo watermarks. Is there an upgrade price from Editor to Editor Plus?



Viewer seems to have Bookmarks but I cannot find the function Named Destinations to be able to compare behavior.

Odd.
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			Hi jotagoman.



In the new upcoming build we will add the new "Use Inherit Zoom" option to the options-menu of NamedDestinations pane. You will be able to turn off it (will be enabled by default) and then create new named destinations with proper zoom level.



Cheers.
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Project Developer



Please archive any files posted to a ZIP, 7z or RAR file or they will be removed and not posted.
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						Re: Named Destination ISSUE . V6 of the Xchange Editor
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						Post
					
								by Willy Van Nuffel » Wed May 30, 2018 7:08 pm
			

			
			
			
			The upgrade question was not answered ...



I see a price difference of 10 EUR for a single user license, between the basic and the Plus version:

https://www.pdf-xchange.com/produc ... or/pricing



I think you can best negotiate an upgrade via an email to sales@pdf-xchange.com

Do not do this via the forum.



Best regards.
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								TrackerSupp-Daniel
							

							Site Admin
	Posts: 8518
	Joined: Wed Jan 03, 2018 6:52 pm



		
						

						
						Re: Named Destination ISSUE . V6 of the Xchange Editor
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						Post
					
								by TrackerSupp-Daniel » Wed May 30, 2018 10:30 pm
			

			
			
			
			Thank for that Willy,

You are correct, an Email to sales@pdf-xchange.com is the best way to have any licensing and purchasing issues addressed in a timely manner. Please do not post any license or purchase details on the public forums.


			
			
									
													Dan McIntyre - Support Technician

Tracker Software Products (Canada) LTD

+++++++++++++++++++++++++++++++++++

Our Web site domain and email address has changed as of 26/10/2023.

https://www.pdf-xchange.com

Support@pdf-xchange.com
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						Re: Named Destination ISSUE . V6 of the Xchange Editor
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								by uk999 » Thu May 31, 2018 2:10 pm
			

			
			
			
			Update.



The information I provided a couple of posts ago that it seemed I needed to upgrade to Editor Pro is wrong. When I returned home, I repeated my experiment with Named Destinations on my home installation of PDFEditor, std. edition. The conversion proceeded exactly as per the office installation except that it did not warn me that to use the convert bookmark to named destination would place a demo stamp on the PDF.



Upon examination further, I discovered that the maintenance cover on the office Editor expired some months ago. Is it really the case that beyond the maintenance agreement that a never-used tool such as convert bookmark to named destination is deemed to be unlicenced, hence printing the demo mark in the document? That seems a bit unusual or unfair.



Oh yes: when do you plan to release the corrective update please?
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								by TrackerSupp-Daniel » Thu May 31, 2018 10:20 pm
			

			
			
			
			Hello uk999,

On the issue with named destinations and Bookmarks, I am having trouble recreating a document that shows this issue in the current version. My zoom levels seem to be retained currently, could I ask you to send a copy of a document you've created with this issue, as well as export your Editor setting for us to test with. Exporting setting can be done under the File > Export settings menu.



On the Licensing point, an expired license should continue working so long as you do not update past the last available version upon expiry, and provided it has not been blocked due to an upgrade.

If you can send a copy of your license key to us via email ( support@pdf-xchange.com ) we can test the issue in the appropriate version for you, and then send you the appropriate installer and/or instructions. Please make a reference to this thread in the email so that we can quickly reference the conversation to this point.


			
			
									
													Dan McIntyre - Support Technician

Tracker Software Products (Canada) LTD

+++++++++++++++++++++++++++++++++++

Our Web site domain and email address has changed as of 26/10/2023.

https://www.pdf-xchange.com

Support@pdf-xchange.com
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