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			Help! I love PDF-XChange Editor and use it all the time, but it has for some reason decided to completely cease functioning.



I have it set to start with the documents open in the last session, of which there were about six. The most recent one (current displayed PDF) rendered fine. But then I clicked on another one, and it would not render the text; only some highlighting which I had added.



The program then became less stable. I'm unable to open it at all because it constantly reports "Not Responding" and I have to kill it. This happens whenever I open the program (noting that it is still attempting to open the last session).



Now begins a sequence of running the setup file again in "Repair" mode (to no avail), then uninstalling and reinstalling multiple times, always with the same "Not Responding" issue. Finally I get to a stage (after some forensic editing of the Windows Registry) where the last session has been forgotten and the program has all defaults set. It starts fine and doesn't hang and I can activate menus, etc. HOWEVER, as soon as I try to open a PDF... "Not Responding." I thought initially that it must have been one of the files in the last saved session was corrupted and causing the issue, but that's not the case; I can not open any PDF at all. It seems like PDF-XChange isn't able to render the text. 



   [image: :?]  



One would think uninstalling and reinstalling would resolve this (and it's a thorough uninstall using Revo Uninstaller to purge any leftovers in the Registry) but the issue remains. It is as if PDF-XChange is reliant on a Windows DLL or some other file responsible for rendering.



I'm no dummy with computers but have spent four hours trying to resolve this and have made no headway... hence my appeal here on the forums. Thank you in advance for any help!
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			1) Did you already try from within PDF-XChange Editor:

> Edit > Reset Settings...

> File > Sessions > Manage Sessions > Remove All sessions



2) Via Windows File Explorer > go to  %appdata% (via the address bar)

Go to the folder "Tracker Software" and delete (or move) the "PDFXEditor" folder
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			Hi Willy, 



Thank you for the assist. 



GWMeaney, 



Please try as Willy suggested. Also, could you please go to Help> About and tell us what version and build you are currently running?



Thank you!


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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			Thank you both for your advice. Here are the results:



First, the version I am now working with is v6 Build 322.4. The issue actually began with an earlier version but in the course of my trying to fix it with uninstalling and reinstalling I upgraded to the latest version. (I'm uncertain which was the version I started with, but not too old. It could have been an earlier build of v6; I still have the earlier install package downloaded on 05 August 2016.)



I have now (from a fresh install) gone to Edit > Reset Settings, selected EVERYthing, and clicked OK.

Under File > Sessions > Manage Sessions the Sessions List is empty, so nothing to do there.

I did indeed previously go to the "Tracker Software" folder in %appdata% and I copied it to my desktop but left the original in place. I have now deleted that original folder.



After all this, the final result: Not Responding. Gah!



Next ideas?



PS. Patrick, Vancouver Island is a beautiful part of the world. Today I live in Sydney, Australia, but I lived in Vancouver for years.
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			Also, for what it's worth, I'm running Windows 10 64-bit.
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			No other suggestions? I fear I am going to have to abandon PDF-XChange Editor for no good reason.   [image: :(]  



I just can't figure it. Could someone intimate with the code comment on whether there is any reliance on particular Windows DLLs for rendering text? It would at least give me a new troubleshooting path; the corruption could perhaps be in Windows.
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			Hi GWMeaney,



Thanks for the info. - I typically work a little over the weekends, but I deal primarily with licensing issues and smaller questions. More complex issues like this will not be answered over the weekend. It's also a bank holiday here, so I'm the only one in today too; I'll do my best to respond and test as quickly as I possibly can, but it's only a bank holiday in the U.K., so I'm on my own while handling the usual volume of support requests and, as I'm sure you can understand, I may not be able to respond as quickly as I'd like.



I'll send an email template with instructions on a fully clean re-install that differs from what you've done previously. Please be sure to following the steps exactly as they appear, then post back here directly and let us know how it went.



Thanks,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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			Great, thanks Will. I've received your email. I'll get back to you shortly here with the results.



No worries about the delay responding. I'm just being impatient! That's just an indicator that you have a well-liked product.   [image: :wink:]


			
			
									
																
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								Will - Tracker Supp
							

							Site Admin
	Posts: 6815
	Joined: Mon Oct 15, 2012 9:21 pm
	Location: London, UK
	
				Contact:
				
					
						Contact Will - Tracker Supp
					
					
						


						
																																								
																	
										Website									
																	

																					

					

				

			



		
						

						
						Re: PDF-XChange Editor Not Responding
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Will - Tracker Supp » Mon May 29, 2017 9:09 am
			

			
			
			
			No worries, looking forward to hearing the results!


No worries about the delay responding. I'm just being impatient! That's just an indicator that you have a well-liked product. [image: :wink:]

Ha! Good to know and very glad to hear! [image: :wink:] Just wanted to let you know so that you didn't think we were ignoring you [image: :)]



Cheers,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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			Hi, Will.



I wasn't very optimistic after having read the instructions in your email template because I already conducted these steps multiple times (using Revo Uninstaller to search for and identify those folders and registry entries). Nevertheless, I have again done precisely as you asked, and I get the same result: the software installs fine, starts fine, and when no PDF is open I can navigate the menus, but as soon as I try to open a PDF—any PDF—the software immediately hangs and I have to kill it as Not Responding.



Is there an error log I can send you?



Wayne
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			Hi Wayne,



Sorry, I wasn't aware that you'd already tried that - There's no logs that will be generated unless the application actually crashes. One final test would be to try disabling the SharePoint plugin via Edit --> Preferences --> Plugins and see if that helps.



If that doesn't help, then I'll speak with the Dev. Team to see what they say, but we may need a remote session to ascertain the cause of the problem.



Cheers,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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			Okay, I in fact tried disabling all the plugins intending, in case that solved the hanging, to work backwards in re-enabling them one by one to identify which may be causing the issue, whether SharePoint or otherwise. However, it made no difference; I get the same result.



I did manage to find a PDF, though, which I can open successfully, which could point to the potential problem. It's a brochure (for wine) and I believe all the text in the PDF is in fact an image rather than actual text, which corroborates my suspicion that the problem is in the ability of the software to render text. (Before the software kept hanging and preventing me from doing anything at all, I did have a PDF open which I had previously marked up with PDFXChange's highlighter pen. The highlighter (which I believe is just an image) was showing but no text was rendered.)



Further substantiating this is that I found another brochure (for an airline) which begins with several pages of images. I was able to open this and click through these first few pages, but then when I got to a page which didn't appear to have any image on it and just appeared as a white page, so presumably is a page of text, the software once again hung as Not Responding.



Another idiosyncrasy is that the mouse pointer disappears when hovering over the open PDF (again, the wine brochure, but I remember this was also happening with that PDF which had the highlighter.)



I hope that can provide the development team with some indication of where the problem lay.



Thanks, Will.



Wayne
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			Hi Wayne,



Thanks for the info., that's definitely extremely interesting. Insofar as I'm aware, we're not reliant on any Windows DLL to render text, but I'm not a developer by any stretch of the term and could be very wrong, so I'll double check that as soon as I'm able.



While from your description the issue certainly doesn't seem to be related to one specific file, but rather all files with text, I'd like to test using a sample document that crashes the Editor for you to make sure that there isn't something specific (and not visually obvious) in common with the documents that you're using.



Also, you mentioned a wine brochure: Do you mean the cross-compatibility layer for Linux? If so, are you running the Editor on Linux via virtual machine, or on native Windows 10?



Cheers,
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Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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			Ha ha... no, I mean a brochure for alcoholic wine made from grapes which you buy in a bottle!   [image: :lol:]  No Linux involved. Native Windows.   [image: :)]  



Shall I send a PDF which crashes my Editor to the support email address?
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			HI Wayne,



thanks for the report and also for sending your files to support@pdf-xchange.com



I am running the same build as you on Win 10 x64 and all the PDF documents you sent me open properly and I can navigate through them.  So far I have been unable to reproduce any issues at all with them.



Do you have access to a second computer that you could test these on?  We need to determine if the issue is document specific or something related to your computer set up.



Are you able to reproduce the behaviour any another system?  



sincerely



Paul
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Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			Hi, Paul.



Per my email, I had hoped the behaviour of the documents would suggest where to look on my machine for the source of the problem.



I will boot into Windows 7 on my machine and test the documents there. Not sure that is going to really tell us anything as the problem is highly unlikely to be document specific. Nevertheless, I understand eliminating all possible causes is part of troubleshooting.



I will need a few days to get back to you.



Thanks for your help.



Wayne
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			Thanks Wayne,



for readers of this thread, we have taken the details off-line and to email.  I will post the results of what happens here however, should anyone be interested.
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Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			This seems to be a very particular problem, but nevertheless it might be interesting to know the solution.



I do not know exactly in which sub folder in the logs of Windows "Event Viewer" there might be a trace of PDF-XChange Editor problems.

(Start > Run > Open: eventvwr + OK) 



Maybe have a look in (Event Viewer) Windows Logs > Application ?

- - - -

And, just for a test ...



Copy the following three files from the "PDF Editor" folder (32-bit) to an empty new folder somewhere:

- PDFXEdit.exe

- PDFXEditCore.x86.dll

- Resources.dat



Start PDFXEdit.exe from there and try to open one of your PDFs.



Does that work, or still not?
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			Thanks Willy [image: :)]



Wayne - I'm not able to find the email thread any more. I'll double check when Paul's in if I don't hear from you beforehand, but has Paul been able to help resolve the issue?



Cheers,
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Best regards
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Tracker Support (Europe)
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			Hi, Will.



Thanks for following up. It is far from resolved, but Paul and I have been discussing troubleshooting approaches. It doesn't look like there will be a quick fix as it seems to be a problem out of the ordinary and not resolved by your standard support instructions. I'm due to conduct a little testing on a different OS on my machine to give Paul more data, and I'm also yet to go through Willy's good suggestions—the Event Viewer is a good idea—but I'm busy for a couple of days and won't be able to do it until at least tomorrow. 



Cheers,



Wayne
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			Hi Wayne,



Glad to hear there's some progress happening!

Do let us know how it went once you've had the time to run the tests and suggestions listed above, and if still needed - we will try to assist you further!



Regards,

Stefan
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			Hi, All.



Sorry for the delay in getting back to this. Had other things on this past week.



I've tested Willy's suggestions to 1) look at the Event Viewer and 2) to try copying the application files to another location and opening the editor from there.



Second test first: copying the files to a new location. First of all, I'm not sure why Willy specifically referenced 32-bit. I've installed the 64-bit version on my 64-bit Win10, and there is no 32-bit folder in Program Files (x86). Maybe this was just an assumption that I was using the 32-bit version, but PDFXChange fully caters for 64-bit systems so that's what I have installed. Nevertheless, I did copy over both PDFXEditCore.x86.dll and PDFXEditCore.x64.dll, along with the other files, though I'm sure the x86 DLL isn't referenced.



Result: nada. Exactly the same error as before.



I had a look in the Event Viewer. Windows Logs > Application does indeed seem to be the only place where anything would turn up, and an entry did when the Editor crashed:


The program PDFXEdit.exe version 6.0.322.4 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.

Process ID: 93c

Start Time: 01d2e0361c015c2c

Termination Time: 12

Application Path: C:\Program Files\Tracker Software\PDF Editor\PDFXEdit.exe

Report Id: 72f6f1db-4c29-11e7-ab0a-305a3a0b36c7

Faulting package full name: 

Faulting package-relative application ID:



Details:


System


		Provider



[ Name] Application Hang



	EventID 1002



[ Qualifiers] 0



Level 2



Task 101



Keywords 0x80000000000000



	TimeCreated



[ SystemTime] 2017-06-08T09:04:23.861130700Z



EventRecordID 559493



Channel Application



Computer Study64



Security




	EventData



PDFXEdit.exe

6.0.322.4

93c

01d2e0361c015c2c

12

C:\Program Files\Tracker Software\PDF Editor\PDFXEdit.exe

72f6f1db-4c29-11e7-ab0a-305a3a0b36c7



55006E006B006E006F0077006E0000000000



Of course, I have no idea what any of that says. Might it mean anything to Support?
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			Hi Wayne,



Thanks for that, it's much appreciated! It doesn't mean a lot to me personally, but hopefully should be useful to the Dev. Team. I'll pass this along now and one of us will get back to you as soon as we've heard something.



Thanks,
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Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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			Hi Wayne,



I've just had a response already! Our project leader, Ivan, has requested a remote session. If this is something that you're amenable to then please see here:

https://www.pdf-xchange.com/knowle ... e-an-issue



For hopefully obvious reasons, please do not post your details here, but instead email support@pdf-xchange.com with a link back to this forum for reference, and please also reference Ivan as the developer if possible, as I'm not in tomorrow and my colleagues may need to pass this along.



Cheers,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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			Thanks, Will. The request for support and indemnity agreement requires licence details. I'm not a licence holder and am using the free version of PDF-XChange Editor (though after this amazing support, I may buy it out of gratitude). I just wanted to clarify that before the Development Team devotes time to resolving this. Is that all okay? Paul intimated that my problem was unusual enough that Tracker would want to know the cause regardless.
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			Hi Wayne,



That's not a problem at all, but I appreciate the honesty and clarification! We typically don't alienate unlicensed users in that way. We view it as an opportunity to improve the product and fix issues that licensed users are also likely to face. We obvioulsy reserve the right to restrict support to licensed users, but typically don't do so.



Cheers,
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Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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			RESOLVED!



Somehow, the problem has fixed itself. I have been having a few minor configuration problems with Windows recently and, while working through them, I discovered that at some point PDFXChange Editor began working again. This vindicates my original suspicion that there was nothing wrong with the software but rather with something that it was calling from the operating system. (I thought originally that it might have been a DLL.)



My best guess as to the source of the problem is User Account Control. I always use Windows (10 Home) with a local administrator account and I turn UAC off because it is such a hideous and badly implemented annoyance. UAC is hard to kill completely, but it can be tamed with some registry edits. However, when I recently overwrote my machine's Master Boot Record (oops!), to restore a working configuration I had to use a few Windows recovery tools, like SFC /scannow, which restores corrupted files to their default states. This revived UAC, so I did some further tweaking and registry edits to tame it again. It was after this that I noticed PDFXChange Editor had come back to life. Hooray!!   [image: :D]    [image: :!:]    [image: :!:]  



Now, it's also possible that simply running SFC /scannow fixed the problem and that it didn't have anything to do with UAC. But in either case, the source of the problem remains with the OS itself.



Though I don't think this information is very helpful, the problem originally started at a time I installed a new SATA expansion card and added two new hard drives to the system. The first install of the card failed, and the machine reset my BIOS settings. After this time I began getting corrected hardware errors appearing in the Event Viewer (only evident there; the system ran fine) relating to the PCI-Express root port. It's a long bow, I know, but it's possible, as this is the only significant event at the time PDFXChange Editor stopped working, that somehow that failed installation changed a Windows configuration which caused the issue.



So happy I have the use of this excellent program back. I use it all the time and, having tried other alternatives to the Adobe bloat such as Foxit, I am convinced that PDFXChange is the best PDF software available.



I also need to say that Tracker Support is exemplary! Patrick, Will and Paul are all praiseworthy representative of the company with their level of support, especially for a user of the free version. Any business considering buying Tracker software should rest assured that it comes with unparalleled support. (Feel free to quote me for any customer testimonials.) And a special shout-out, too, to community member Willy.   [image: :)]  



I hope my brief analysis here helps Support develop troubleshooting paths for any similar issues customers might encounter in the future. If there's not enough information here, or if the developers have any further questions, or if anyone wants me to run any additional tests, I would be happy to help.



Cheers!
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			Awesome, glad to hear that it's resolved Wayne [image: :D] 



Thanks for the kind words too, they're always greatly appreciated [image: :)]
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Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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