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								by Don_Pedro » Mon Jul 23, 2012 1:46 pm
			

			
			
			
			Hello,

I'm using PDF-XChange Viewer Pro V. 2.5.204 on my new Windows 7 (64 bit) computer.  There are two other PDF viewers installed: Adobe Acrobat Reader and Sumatra PDF.



For some reason, PDF XChange Viewer cannot locate other PDF viewers.  The start button in the lower right corner just shows an orange flash symbol ("no alternate PDF viewers available").



I checked the registry and found the following entries that might be related to this issue:

HKCU\Software\Tracker Software\PDFViewer\General\AltApplicationModulePath ="C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe"

HKCU\Software\Tracker Software\PDFViewer.IBrowser\General\AltApplicationModulePath ="C:\Program Files\Tracker Software\PDF Viewer\PDFXCview.exe"



The paths to Sumatra and PDF XChange Viewer are correct.  I edited the registry entries and replaced the path to SumatraPDF with the correct path to Adobe Reader ("C:\Program Files (x86)\Adobe\Reader 10.0\Reader\AcroRd32.exe").  Unfortunately, this does not work.  The path to Adobe Reader appears to be replaced automatically with the path to SumatraPDF when XChange Viewer ist started.  The start button still isn't working as it should (displays orange flash symbol and "no alternate PDF viewer available").



1. How can I direct XChange Viewer to find and remember the path to alternate PDF viewers?

2. Are several alternate viewers supported, or does this feature only work for Adobe Reader?



Thanks a lot.
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			Hello Don_Pedro,



You need to have had Adobe reader and Sumatra installed before our Viewer, and then when you install our Viewer - it will detect Adobe and include it in that menu. Unfortunately it will not work with listing Sumatra in that drop down menu.



Best,

Stefan
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								by Don_Pedro » Tue Jul 24, 2012 6:27 pm
			

			
			
			
			Hello Stefan,



thanks for your help.  I followed your advice, and things seem to be working now.  I can see the Adobe logo in the lower right corner of the window.



I uninstalled X-Change Viewer and Sumatra and restarted my PC.  I set Adobe Reader as the default application for opening PDF files.  Then I installed X-Change Viewer and finally Sumatra.



Just for the record: it appears that X-Change Viewer cannot locate Adobe Reader if another PDF viewer (such as Sumatra) is installed on the system parallel to Adobe Reader before X-Change Viewer.  So the correct order of installation seems to be:

1. Adobe Reader

2. X-Change Viewer

3. other PDF viewers 



Best regards.
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			Hi Don,



that's interesting as it shouldn't make a difference.  We simply look to the registry for Adobe Reader and Acrobat, get the install path from there and if it's present use that to call Adobe.



It's good to hear though because things are often not quite what one expects.



[image: :-)]


			
			
									
													Best regards



Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			Can you add option to manually add other PDF viewers on user's system? That would be very helpful!
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			Hello ZoNi,



We do not have such plans for the moment.



Best,

Stefan
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			Oh, well... For us that use many portable programs, that "flash" button is useless [image: :(]
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								by Tracker Supp-Stefan » Tue Sep 04, 2012 10:22 am
			

			
			
			
			Hi ZoNi,



Then you can hide it - that's the Launch Toolbar so you can turn it off from The Viewer's Main menu -> View -> Toolbars.



Best,

Stefan
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			Why to try something other than Adobe reader, I guess that's the best pdf reader..[image: :)]
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			Hello planetbob,



And welcome to our forums, but your post is in a topic that is already resolved so could you please elaborate on why you made that remark here?



Cheers,

Stefan


			
			
									
																
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								Bhikkhu Pesala
							

							User
	Posts: 1776
	Joined: Tue May 29, 2007 9:29 am
	Location: East London
	
				Contact:
				
					
						Contact Bhikkhu Pesala
					
					
						


						
																																								
																	
										Website									
																	

																					

					

				

			



		
						

						
						Re: Alternate PDF Viewers not found
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Bhikkhu Pesala » Wed Sep 05, 2012 9:21 pm
			

			
			
			
			I think its pretty obvious that planetbob has never done any objective testing of other PDF viewers, or he would not state that Adobe Reader is the best. As with all software, some products are the best in some areas, but not in others. It all depends on what your priorities are in deciding which is the best product for your purposes.



Finding Text across a whole folder full of PDF files takes almost five times as long as PDF-XChange or Foxit Reader. Adobe Reader is about eight times slower at searching a very large file, while Foxit Reader just cannot cope at all, and crashes with an abnormal program termination.
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			Hi Bhikkhu,



We've had quite some increase in the spam activity in the forums lately, and while most are obvious and easy to remove before even shown to non moderators - I am however not 100% sure for planetbob's comment. So my earlier post is an attempt to provoke him/her to post something that would fail a machine on a "Turing test".



Best,

Stefan
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			Tracker Supp-Stefan wrote:Hi ZoNi,



Then you can hide it - that's the Launch Toolbar so you can turn it off from The Viewer's Main menu -> View -> Toolbars.



Best,

Stefan


Yeah, I forget that possibility [image: :)] Will do that and ask you to add my suggestion (manual adding of alternate PDF readers) to some "to-do" list [image: :)] Or add it in File menu (File > Open with > ...)


			
			
									
																
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								Tracker Supp-Stefan
							

							Site Admin
	Posts: 17853
	Joined: Mon Jan 12, 2009 8:07 am
	Location: London
	
				Contact:
				
					
						Contact Tracker Supp-Stefan
					
					
						


						
																																								
																	
										Website									
																	

																					

					

				

			



		
						

						
						Re: Alternate PDF Viewers not found
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Tracker Supp-Stefan » Thu Sep 06, 2012 9:50 am
			

			
			
			
			Hi ZoNi,



I will ask again before including it in a ToDo list, but I believe this has been discussed before and rejected as a feature [image: :(]



So not making any promises here.



Best,

Stefan
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			Tracker Supp-Stefan wrote:I believe this has been discussed before and rejected as a feature


Hm... Can you, please, explain me why is that rejected? Is it too complicated (I don't think so) or, maybe, you don' want to give any option to "link" PDFX and competition? [image: :)]
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			Hi ZoNi,



In the past our Viewer had some difference in the way it was displaying files with the then bigger competitors [image: :)]

As time passes and we improve our Viewer, Adobe's Reader/Acrobat is the only product that still displays some pdfs better than our Viewer, and that's why this is the only alternate viewer left in this menu. Hopefully with the introduction of v3 of the PDF XChange Viewer we would be able to completely remove this button as is our intention. So the ability to manually add third party PDF viewers to that soon to be obsolete toolbar has been rejected.



Best,

Stefan
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			Hey guys don't worry i am not a spammer [image: :)], just that my knowledge on other pdf readers is a bit low that's why thought Adobe is the best..
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			I recently discovered PDF-XChange Viewer and was pleasantly surprised to see that it listed my other viewers on the Launch Toolbar. This actually convinced me to make PDF-XC my default viewer, since I could easily launch the document with another viewer if needed.



However, on my second machine, not all the viewers were there (some were portable versions, just like PDF-XChange, so on this machine, the portable programs didn't show up). I was disappointed and kept looking for a way to manually add my other programs. Then I found this forum/thread.



Allowing additional programs to manually be added to the Toolbar would be a great feature:

1) There are times that I'd like to see how a document looks in an alternate viewer (simply because I can't be sure that everyone I send a document to is using  PDF-XChange). This is similar to looking at a web document from multiple browsers to make sure they are readable across multiple applications.



2) Also, I have several specialty PDF programs that I use in conjunction with my viewers, it would be great if those programs could be launched from PDF-XChange (specifically loading the same document with these other programs).



I don't limit myself to a single browser, I use different ones for different purposes. Similarly I'm also going to use different PDF utilities, depending on my needs. It's not about showing/hiding the competition, it's about the usefulness of a given program. Having a customizable Launch Toolbar increases the usefulness of PDF-XC (and makes it more likely to be the default program).



Oh, and since this is my first post in this forum:

HI!  [image: :mrgreen:]
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			Hello Muad`Dib,



And welcome to our forums! [image: :)]



Many thanks for the kind words. The Viewer unfortunately relies on the registry to recognize other installed PDF applications and as such - portable products won't be recognized.



As for the request to be able to add other apps in the "Launch toolbar" - I do not think this is something we are considering right now, but things might change once V3 of our Viewer is released.



Best,

Stefan
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			I just want to tell I would be sad to see the launch button not be there anymore (and I would like to be able to add some programs) AND I TOTALLY AGREE with Muad`Dib "Having a customizable Launch Toolbar increases the usefulness of PDF-XC (and makes it more likely to be the default program)." I love pdf XChange and I love this launch button...



Thanks to keep that in consideration!
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			Hello zibudizz,



Welcome to our forums! Your voice is heard and will be taken into consideration!



Best,

Stefan
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			Muad`Dib wrote: Having a customizable Launch Toolbar increases the usefulness of PDF-XC (and makes it more likely to be the default program).



Can you not simply use the weirding way to open alternate viewers, muad'dib?   [image: ;)]



Welcome to the forum!
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			Walter-Tracker Supp wrote:Can you not simply use the weirding way to open alternate viewers, muad'dib?   [image: ;)]

The Weirding Way was the first thing I used, but I think I've become a bit careless in my technique, because every time I tried it I would break my computer!



Or maybe the Weirding Way isn't compatible with Windows?
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			Hi Muad`Dib,



perhaps if you used the name Usul???



We used to allow third party Viewers to be launched in the Viewer years ago and have made the decision to limit it to Adobe, and yes it is dependant on reg keys for the Adobe InstallPath variable to call the Reader executable.  



I doubt that this will change back to allowing third party Viewers.


			
			
									
													Best regards



Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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