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Rotate document by 1 or 2 degrees?


Forum for the PDF-XChange Editor - Free and Licensed Versions
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								Robert13
							

							User
	Posts: 124
	Joined: Fri Dec 09, 2011 4:53 pm



		
						

						
						Rotate document by 1 or 2 degrees?
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Robert13 » Wed Jul 09, 2014 11:51 am
			

			
			
			
			Is there a way to rotate a document by just a degree or 2.

I get scanned documents that were put into the scanner slightly rotated and would like to get them straightened up.

Is this possible or maybe this is an feature request.



Thanks
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								Tracker Supp-Stefan
							

							Site Admin
	Posts: 17853
	Joined: Mon Jan 12, 2009 8:07 am
	Location: London
	
				Contact:
				
					
						Contact Tracker Supp-Stefan
					
					
						


						
																																								
																	
										Website									
																	

																					

					

				

			



		
						

						
						Re: Rotate document by 1 or 2 degrees?
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Tracker Supp-Stefan » Wed Jul 09, 2014 2:15 pm
			

			
			
			
			Hi Robert,



The PDF Page itself has to be rectangular and orthogonal to the screen, but you can rotate the contents inside.

Go to Tools -> Content Editing Tools, and you can then select and rotate the image as necessary.



Regards,

Stefan
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						Re: Rotate document by 1 or 2 degrees?
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								by Robert13 » Wed Jul 09, 2014 4:53 pm
			

			
			
			
			Perfect, just what I needed.



Thanks [image: :D]
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						Re: Rotate document by 1 or 2 degrees?
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Robert13 » Mon Nov 24, 2014 4:20 pm
			

			
			
			
			Has this changed since July, I can't seem to do this?
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								Will - Tracker Supp
							

							Site Admin
	Posts: 6815
	Joined: Mon Oct 15, 2012 9:21 pm
	Location: London, UK
	
				Contact:
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						Re: Rotate document by 1 or 2 degrees?
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								by Will - Tracker Supp » Mon Nov 24, 2014 4:24 pm
			

			
			
			
			Hi Robert,



I don't believe that there have been any changes, you should still be able to rotate the contents as Stefan previously advised. Is this specific to one document? If so, please do send the document. If you don't want the document to be publicly available, then please send it to support@pdf-xchange.com



Cheers,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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								Vasyl-Tracker Dev Team
							

							Site Admin
	Posts: 2353
	Joined: Thu Jun 30, 2005 4:11 pm
	Location: Canada



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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								by Vasyl-Tracker Dev Team » Thu Nov 27, 2014 2:01 am
			

			
			
			
			Hi Robert.


I get scanned documents that were put into the scanner slightly rotated and would like to get them straightened up.


If you using our Scan-To-PDF feature to create such documents then you may try to use additional option 'Deskew':

http://www.docu-track.co.uk/img/ScanWithDeskew.png

When you enabled it then editor will try to detect slightly rotated images and automatically correct their rotation...



HTH.


			
			
									
													Vasyl Yaremyn

Tracker Software Products 

Project Developer



Please archive any files posted to a ZIP, 7z or RAR file or they will be removed and not posted.
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						Re: Rotate document by 1 or 2 degrees?
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			I'm not seeing the feature to rotate images either under Tools -> Content Editing Tools. I see only Edit Content Tool and Add Text.
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						Re: Rotate document by 1 or 2 degrees?
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			And I accidenlty discovered how to do it.  [image: :P] 



With the Edit Content Tool selected, I can click on an image and select the rotation handle and rotate it around. I don't see a way to know the number of degrees and it's one image at a time.
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								Patrick-Tracker Supp
							

							Site Admin
	Posts: 1645
	Joined: Thu Mar 27, 2014 6:14 pm
	Location: Vancouver Island
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													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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						Re: Rotate document by 1 or 2 degrees?
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			Any way to specify an amount and do it for multiple pages? 

Or would that be a feature request?
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								Will - Tracker Supp
							

							Site Admin
	Posts: 6815
	Joined: Mon Oct 15, 2012 9:21 pm
	Location: London, UK
	
				Contact:
				
					
						Contact Will - Tracker Supp
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						Re: Rotate document by 1 or 2 degrees?
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								by Will - Tracker Supp » Wed Dec 03, 2014 10:05 pm
			

			
			
			
			Hi Paul,



I'm afraid that there isn't currently any way to specify the number of degrees by which you would like to rotate the image, or over how many pages. I will forward this on to the Dev. Team for consideration in later release.



Cheers,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Best regards



Will Travaglini

Tracker Support (Europe)

Tracker Software Products Ltd.

http://www.tracker-software.com
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								Jensen Head
							

							User
	Posts: 417
	Joined: Mon Sep 13, 2021 8:12 am



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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						Post
					
								by Jensen Head » Mon Sep 13, 2021 8:44 am
			

			
			
			
			It seems to me that the skew alignment tool in FastStone Image Viewer has been implemented very well. In this application, the tool is called "Straighten / Rotate by any Degree", and it works as follows: the user presses LMB at the beginning of an imaginary line segment, releases at the end of this segment. The image is rotated so that this ball line is horizontal or vertical (whichever is closer). In PDF-XChange Editor Plus, this rotation angle method could be used to rotate pages by an arbitrary angle. The way it is implemented now is inconvenient because the rotation marker of the entire page content is outside of it, and is not available when zooming in. That is, the turning accuracy is very rough.
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								Ovg
							

							User
	Posts: 461
	Joined: Tue Sep 05, 2017 4:56 pm



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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								by Ovg » Mon Sep 13, 2021 9:39 am
			

			
			
			
			try:

Enable edition of images

RMB on image, then Arrange->Transform
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								David.P
							

							User
	Posts: 1520
	Joined: Thu Feb 28, 2008 8:16 pm



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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						Post
					
								by David.P » Mon Sep 13, 2021 12:54 pm
			

			
			
			
			Hello all, 



why not simply using the "Deskew" function in PDF-XChange Editor?



I find that this works excellent, also in case the pages are just very slightly skewed. 
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Of course, the same can be achieved with the OCR function.



Regards
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PDF-XChange Pro
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								Jensen Head
							

							User
	Posts: 417
	Joined: Mon Sep 13, 2021 8:12 am



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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						Post
					
								by Jensen Head » Mon Sep 13, 2021 1:30 pm
			

			
			
			
			David.P wrote: ↑Mon Sep 13, 2021 12:54 pmWhy not simply using the "Deskew" function


Thanks, didn't know about this feature! In most cases, it works correctly. But you need a handy WYSIWYG tool to fix the skew of those pages where the "Deskew" function was wrong.
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								David.P
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	Posts: 1520
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						Re: Rotate document by 1 or 2 degrees?
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								by David.P » Mon Sep 13, 2021 3:41 pm
			

			
			
			
			I agree, also and especially with your feature request:


Jensen Head wrote: ↑Mon Sep 13, 2021 8:44 am
It seems to me that the skew alignment tool in FastStone Image Viewer has been implemented very well. In this application, the tool is called "Straighten / Rotate by any Degree", and it works as follows: the user presses LMB at the beginning of an imaginary line segment, releases at the end of this segment. The image is rotated so that this ball line is horizontal or vertical (whichever is closer). In PDF-XChange Editor Plus, this rotation angle method could be used to rotate pages by an arbitrary angle. 
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...which would be a great addition to PDF-XChange Editor.



Best regards

David
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PDF-XChange Pro
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	Joined: Tue Jun 09, 2009 3:53 am
	Location: Florida



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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								by Arnold » Mon Sep 13, 2021 10:33 pm
			

			
			
			
			There are times when a feature like this would come in handy.
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								TrackerSupp-Daniel
							

							Site Admin
	Posts: 8521
	Joined: Wed Jan 03, 2018 6:52 pm



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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						Post
					
								by TrackerSupp-Daniel » Fri Nov 05, 2021 7:39 pm
			

			
			
			
			Hello, everyone



Sorry for the delay on this, Though I cannot promise that it will be implemented, I have created a formal ticket for the request here today:



RT#5789: FR: Manual deskew



Kind regards,


			
			
									
													Dan McIntyre - Support Technician

Tracker Software Products (Canada) LTD

+++++++++++++++++++++++++++++++++++

Our Web site domain and email address has changed as of 26/10/2023.

https://www.pdf-xchange.com

Support@pdf-xchange.com
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								Jensen Head
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	Joined: Mon Sep 13, 2021 8:12 am



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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						Post
					
								by Jensen Head » Mon Nov 22, 2021 10:54 am
			

			
			
			
			A related topic — "Manual Deskew (de-skew)" https://forum.pdf-xchange.com/viewtopic.php?f=70&t=37317



To test new methods for automatic skew correction, I added a PDF-file in which the PDF-XChange Editor does not automatically correct skew ("Deskew Pages" tool) — https://drive.google.com/open?id=16Uf0c4V3m_USGffInsj7lcpPfvnOstXN (PDF, 7 MB).
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								Tracker Supp-Stefan
							

							Site Admin
	Posts: 17853
	Joined: Mon Jan 12, 2009 8:07 am
	Location: London
	
				Contact:
				
					
						Contact Tracker Supp-Stefan
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								by Tracker Supp-Stefan » Mon Nov 22, 2021 11:43 am
			

			
			
			
			Hello Jensen Head,



Thanks for the sample. I've downloaded a copy and included it in the ticket so that it can be considered when our devs are testing and implementing such a feature.



Kind regards, 

Stefan
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	Joined: Sat Jun 04, 2016 5:55 pm



		
						

						
						Re: Rotate document by 1 or 2 degrees?
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								by StreifLicht » Sat Mar 12, 2022 12:28 pm
			

			
			
			
			I have the same problem. I have a scanned drawing (layout) which I have to rotate by 1 orv 2 degrees to straighten the page. I have already tried to use the command deskew, but with zero success.

So my question is: How I can straighten a page to get it orthogonal?
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								Tracker Supp-Stefan
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			Hello StreifLicht,



Please select the "Edit Content" tool, and then click on your scanned image - this should then allow you to rotate that object relative to the page at any degree. The PDF Page itself will remain orthogonal.



Kind regards, 

Stefan
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