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								by BywaterNYC » Mon Jun 19, 2017 5:28 pm
			

			
			
			
			Am a new user, and wish I'd discovered this software years ago. It's fantastic! 



Two remedial questions....



Can you tell me how to launch the "New Document" option? If I understand the manual correctly, the option should be visible on the File menu. However, it seems to be MIA:



[image: Image]



Also, I use the Typewriter function quite a bit. For on-the-fly formatting, I've pinned these shortcuts to my toolbar:



[image: Image]



Is there a toolbar shortcut for changing the font color—an alternative to going into Properties? 



Kind thanks for your help.



Brooks   [image: Image]


			
			
									
													PDF-XChange Editor 9.3 (Build 361.0)

Win 10 Pro x64
			
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								Patrick-Tracker Supp
							

							Site Admin
	Posts: 1645
	Joined: Thu Mar 27, 2014 6:14 pm
	Location: Vancouver Island
	
				Contact:
				
					
						Contact Patrick-Tracker Supp
					
					
						


						
																																								
																	
										Website									
																	

																					

					

				

			



		
						

						
						Re: "New Document" menu option
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Patrick-Tracker Supp » Mon Jun 19, 2017 5:49 pm
			

			
			
			
			Hello BywaterNYC, 



Thank you for your post and welcome to our community forums! That is indeed very strange to see (or, rather not)! The new document options should indeed be listed there: 



[image: Image]



Could you please go to Edit> Export Settings and make sure to export and save your settings file. Once you have saved the settings, please go to Edit> Reset Settings. Please then check if the "New Document" menu is there. 



Failing that, please let me know what version and build you are running, as well as your version of Windows. 



Thank you!


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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			Thanks for the friendly welcome, Patrick, and for your help.



After exporting my settings and resetting the software, the missing "New Document" option magically reappeared. So that's the good news!



Ominously, after restoring my saved settings, "New Document" vanished again. Am almost afraid to ask, but....



Does this mean I'll need to reset and retweak all of my settings from scratch? I'm embarrassed to admit how many hours I spent yesterday, tuning and fine-tuning—like, all day. Waaaaa!



Info about my software version and OS is, I believe, in my signature, but for the record:



Version 6 (Build 322.4)

Win 7 Pro x64



Thanks again.



B.
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			Reset of "all" your settings is rather "drastic".



So, first please restore your saved settings.



After this, please try to resolve the problem by only resetting the File menu, in the following manner:

- right click on whatever of your toolbars

- click "Customize Toolbars..." (the very last item in the shortcuts menu)

- now, do a right mouse click on the File-menu

- click "Reset Toolbar"

- click Close in the "Customize Toolbars" dialog box



Does this make a difference?



Best regards.
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			Appreciate your help, Willy.



I ran several resets of the File menu as per your instructions. No dice, unfortunately. The problem persists.
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			I do not know for sure if you tried instructions in my edited answer.



If yes, then I am sorry that it does not help.
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			Hello BywaterNYC, 



Thanks for trying what Willy suggested. Please post your settings file here so that I can take a look and see what we can do. Please note that you will need to save the settings file in a zip. archive in order to post it here. 



Thank you!


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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			Hi BywaterNYC, 



A thought has occurred: is this option selected under edit> Preferences> Registration: 



[image: Image]



If so, it would explain why these options are hidden. 



HTH!


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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			Appreciate all your help, guys.



Yes, Willy, I followed your edited instructions. With a run-of-the-mill problem, I'm guessing your solution would have worked. Thanks for trying!



And thank you, Patrick. Settings zipped, and comin' atcha..........CATCH! (The "Hide all licensed features from toolbars and menus" option was not selected. Good call, though.)



For now, I've taken screenshots of my toolbar, as well as my Preference settings. If I need to start over from scratch, the re-tweaking shouldn't take too long.
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			Perhaps I should have mentioned that during the initial software installation, I chose to do a custom install. There were optional features that I knew I wouldn't use, and so I didn't install them.



For what it's worth!
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			Hello,



In your uploaded ZIP file, I only find a settings file (*.xces), no print screens.



For a test, I imported this settings file, and indeed the "New document" entry was gone out of the File-menu.



But, easily enough, when I execute a reset of the File-menu, the "New document" entry returns and it stays, even after closing and restarting the Editor.



I have included a print screen (*.png) of what I see during the reset.



Can you please check, when you execute a global reset (like Patrick first suggested), if the New document entry stays after closing and restarting, and also check if you can indeed create a new document on the hand of that entry. So, we are sure that this feature is NOT missing eventually.



Is it possible that you do not right-click the File-menu itself but rather the "File" entry in the "Customize Toolbars"-dialog box, when you click reset?



Best regards.
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			Hi BywaterNYC,



I get the same as Willy, (thanks for that Willy).



You mentioned you chose only certain components during install.  Which ones specifically?  As far as I am aware that should not result in the behaviour you are seeing so I am keen to reproduce the issue here.



I would also be interested in knowing if a default install stops this behaviour on your PC.  Is that something you would consider testing?
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Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			Hello BywaterNYC,



Thank you for providing your settings. This is pretty consistent, and I suspect you may have inadvertently deleted that menu item. Please go to View> Toolbars> Customise Toolbars then click on the file menu and right click any option and choose "Reset menu"



[image: Image]



I hope this helps!


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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			Willy Van Nuffel wrote:In your uploaded ZIP file, I only find a settings file (*.xces), no print screens.


Willy, I only meant that I took screenshots of my preferences for my own use, in case I need to reinstall the software from scratch. That way, I can refer to the pics while re-tweaking, and hopefully save some time. I didn't include those screenshots in the zip file I uploaded here.


Is it possible that you do not right-click the File-menu itself but rather the "File" entry in the "Customize Toolbars"-dialog box, when you click reset?


Willy, THAT'S IT! GAHHHH! I feel like World's Biggest Idiot™, because that's exactly what I did. I was clicking inside the Customize Toolbars box......:



[image: Image]



.....when, as per your screenshot, I should have clicked here:



[image: Image]



 The New Document feature is back on my file menu, and still there after I've closed and restarted the software. And the feature works. I've created a new document "With Blank Pages," and a new document "From Image File(s)." 



Best of all, I get to keep my customized settings!


Patrick-Tracker Supp wrote:Please go to View> Toolbars> Customise Toolbars then click on the file menu and right click any option and choose "Reset menu"


That works too!



Guys, I'm immensely grateful for your help and patience, and apologize for my careless mistake. 


Paul - Tracker Supp wrote:You mentioned you chose only certain components during install.  Which ones specifically?


Gosh, Paul, off the top of my head, I can't remember. If anyone here wants to post a list of those optional components, I can easily pick out the ones I did, and didn't, install.


I would also be interested in knowing if a default install stops this behaviour on your PC. Is that something you would consider testing?


Sure. Today's adventure has fried my old brain, so I won't be doing it today. But I will. 



Finally, is there a toolbar shortcut for changing the color of a Typewriter font? Making the change in Properties is easy enough. I was just wondering.



Wishing you all a pleasant evening, wherever you are. Thanks again, and goodnight!



[image: Image]



Brooks
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			Hello Brooks,



With your permission - I'd like to use your "TM" title sometimes for myself when I have similar moments! [image: ;)]

Glad that you finally got to the bottom of it, and did reset only the menu as ! That should save you the full reset or full reinstall and then customizing all the rest of the menus back to your preference! Also - Paul's questions were aimed at getting to the bottom of the problem - but now that it is resolved - trying out a full reinstall or figuring out which features you skipped might no longer be necessary. 



As fro the latest question - I believe this will help:

How do I quickly access variations of a specific Tool

It shows how to create separate styles and even assign specific keyboard shortcuts to each.



Regards,

Stefan
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			Tracker Supp-Stefan wrote:With your permission - I'd like to use your "TM" title sometimes for myself when I have similar moments! [image: ;)]



Stefan, I shouldn't lay exclusive claim to world's "Biggest" idiot when it's such a highly competitive field. Help yourself to the trademark as needed, and toot your Idiot Horn™ with pride! .    [image: :mrgreen:]  



Regarding Typewriter font color, thanks for the helpful link. It looks like the solution!



Am guessing you haven't seen the last of me, although I will try hard not to make a nuisance of myself.



To all of you, thanks again for the friendly help.



Brooks
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			Hello Brooks,



Many thanks for "sharing the rights" [image: :P]



Enjoy using our software! And if there's anything else we can help with - feel free to open up a new topic for it!



Cheers,

Stefan
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