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						How to import settings in V7?
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						Post
					
								by megacable » Fri Dec 08, 2017 1:24 pm
			

			
			
			
			Hi!



I just updated from v6 to v7, read the changelog before which says
Introduced the new Ribbon UI, with the option to switch back to Classic UI as desired. WARNING: when you migrate from V6 to V7 - you will LOSE(!) any existing toolbar customization. Please export your settings to an external file if you wish to retain them. We are working on a feature that will import V6 customization to V7.



So I exported my settings via "Edit" toolbar menu.



V7 doesn't have an Edit toolbar menu. So how to I import my settings? There's lots of stuff I don't need cluttering the top of the window. Actually I can't even find how to switch back to classic in the preferences.



Greets,

megacable



/edit

Nevermind, I found the little little icon on the very top right that opens a different menu than Help tab --> UI Options (Why are settings in "help" and not "home" or something?)



/edit 2

Uhm, importing settings was not as expected. It still needs much more vertical space than before. I'll just downgrade for now and see, if I've got some time over christmas customizing it again.


			
			
									
																
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																			

								Willy Van Nuffel
							

							User
	Posts: 2376
	Joined: Wed Jan 18, 2006 12:10 pm
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			Hello megacable



The goal is to export your settings/customizations of PDF-XChange Editor V6 BEFORE migrating to PDF-XChange Editor V7.

So, you have a back-up copy of your (old) settings.



Like the warning says "We are working on a feature that will import V6 customization to V7."

This means that (correctly) importing your old V6 settings/customizations in V7 is NOT YET possible for now.



At this moment, you have the choice to stay with Editor V6 until the feature is available OR to migrate to Editor V7 and to either:

- use the new lay-out as it is

- manually redo your customizations

- use the new lay-out for now, and import your V6 customization settings from the moment that the import feature is available in Editor V7



Best regards.
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			export your settings/customizations of PDF-XChange Editor V6 BEFORE migrating to PDF-XChange Editor V7


I did that. Still after import, it looked a lot different. Maybe I can provide comparing screenshots later.


This means that (correctly) importing your old V6 settings/customizations in V7 is NOT YET possible for now.


I misunderstood it as "it's not automatically possible for now".



No worries, I'll just wait. That can happen if one does a manual update. I'm sure it wouldn't have happened if it was the automatic update.



Best regards,

megacable
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								by Vasyl-Tracker Dev Team » Fri Dec 08, 2017 8:24 pm
			

			
			
			
			I misunderstood it as "it's not automatically possible for now".


To be clear: V7 uses the same settings from V6. Both versions uses the same settings. Excepting one - currently the V7 ONLY doesn't support the toolbars customization that was made in V6. 

BUT all other settings are supported and used by V7 as well.



In the near future we planning to add auto-import old toolbars customization feature. If you want to keep your toolbars customization - before first start of V7 - export all your settings to an external file and wait for build with such auto-import feature.



Cheers.


			
			
									
													Vasyl Yaremyn

Tracker Software Products 

Project Developer



Please archive any files posted to a ZIP, 7z or RAR file or they will be removed and not posted.
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			Hi Vasyl,



Thanks for making this clear to us.



Myself I was too hard focused on the problem with the "toolbar customizations", that I also included the "settings" in it.



Knowing this, what do you think about making a distinction between these two items in the import/export settings option ?

In that way it would be possible for current V7 users to only import their "toolbar customizations" once that the import feature allows to do this.

It might be that they do not want their new V7 "settings" to be touched again.

EDIT: I see that you were already planning this idea. Splendid!



Best regards.
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			Yeah, no worries, I'm cool with that.

I just put most configuration time into customizing the toolbars to make them slim and only show my most needed tools and buttons.

As an enduser, the things you mostly notice are the UI changes, although programmers might have done a lot "behind the curtain".



I'll do as instructed!



Thanks,

megacable
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													Best regards



Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			I installed V7 of PDF-XChange Editor on two separate computer.  After customizing Editor on one of the computers, I exported the settings (using File > Export Settings) and tried to import them into PDF-XChange Editor on my other computer (using File > Import Settings).  When I did this, PDF-XChange Editor closed/crashed.  When I reopened PDF-XChange Editor none of my settings were applied.  I tried to import the settings again with the same result.  Does anyone have any thoughts on what may be causing this?  Thanks!
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								by David.P » Tue Dec 12, 2017 7:47 am
			

			
			
			
			Hi @all,
Vasyl-Tracker Dev Team wrote:To be clear: V7 uses the same settings from V6. Both versions uses the same settings. Excepting one - currently the V7 ONLY doesn't support the toolbars customization that was made in V6. 

BUT all other settings are supported and used by V7 as well.


Could it be that also custom keyboard shortcuts are not imported/taken over from v.6? I had lots of them in v.6, but they all seem to have gone after importing the v.6 settings in v.7.


			
			
									
													David.P

PDF-XChange Pro
			
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								Paul - Tracker Supp
							

							Site Admin
	Posts: 6866
	Joined: Wed Mar 25, 2009 10:37 pm
	Location: Chemainus, Canada
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			Hi David,


Could it be that also custom keyboard shortcuts are not imported/taken over from v.6?



Correct - those are part of the customisation and will not be applied to V7.



hth


			
			
									
													Best regards



Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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			OK Paul, thank you for the clarification!
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													Best regards



Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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								by Willy Van Nuffel » Tue Dec 12, 2017 9:31 pm
			

			
			
			
			So, there is a plan to import Editor V6 "toolbar customizations" in V7 in the near future, and there is NO plan to do the same for "keyboard shortcuts" ?



Import V6 "settings" in V7, already works.



Regards.


			
			
									
																
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								Paul - Tracker Supp
							

							Site Admin
	Posts: 6866
	Joined: Wed Mar 25, 2009 10:37 pm
	Location: Chemainus, Canada
	
				Contact:
				
					
						Contact Paul - Tracker Supp
					
					
						


						
																																								
																	
										ICQ									
																																																
										Website									
																	

																					

					

				

			



		
						

						
						Re: How to import settings in V7?
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by Paul - Tracker Supp » Tue Dec 12, 2017 10:12 pm
			

			
			
			
			So, there is a plan to import Editor V6 "toolbar customizations" in V7 in the near future, and there is NO plan to do the same for "keyboard shortcuts" ?



kind of...  we do plan to try making the keyboard shortcuts also import but at present we cannot promise it.

[image: :-|]
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Paul O'Rorke

Tracker Support North America

http://www.tracker-software.com
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						Re: How to import settings in V7?
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						Post
					
								by pedro henrique garcia » Thu May 03, 2018 12:05 pm
			

			
			
			
			How is the progress for being able to import toolbar customization from V6 to V7 going? They have locked the most popular post about it, so I don't think this will happen as they have promised. 

This is unfortunate and just extremely frustrating, because I used to recommend PDF XChange to everyone I know and got quite a few people to regularly start using it (by giving them a copy of my toolbar customization's settings). 

If I upgrade to V7, I will lose everything. 

This is just straight up user hostile development. 

And then they are suggesting that I spend 2 hours of my day redoing all the work I made. 

I'll just keep using V6 instead, and point everyone to use Foxit Reader instead. 

This is just insulting.
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			@pedro

Can't really help you here, but tell you my story.



By now I ended up with a more radical solution:

No more icons / ribbons. Just the classic small text-based menu.



I often couldn't tell the functions / icons apart and was too lazy customizing everything again.

As vertical space is the most valuable thing when displaying a sheet of paper in portrait mode on a 16:9 widescreen, I now defined a bunch of shortcuts, learned them during one week and I'm happy with it.



I realized how few functions I regularly use and that I actually don't need 90% of the stuff that is there or that I can live without it. Almost a bit like SumatraPDF but more comfortable and customizable.



Despite my shortcuts definitions, I don't fear anything now [image: ;-)]



Greets,

megacable





/edit: Of course I meant vertical space, not horizontal


			
			
													
					Last edited by megacable on Thu May 03, 2018 1:49 pm, edited 1 time in total.
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			Hi all,



I agree that this can be frustrating. I felt like this as well. The case indeed is a little unfortunate, also because the longer it takes to implement that "transfer settings from v.6 to v.7" feature, the less it is needed, because most users probably will have switched to v.7 anyway, by the time the feature will be available.



I can only recommend again to run one's installed copy of PDF-XChange Editor v.6 alongside with a portable version of the v.7 Editor, for example on two different monitors (or vertically one above the other on a single monitor). This way, it is rather easy and straightforward to complete any toolbar customizations, and even to transfer all keyboard shortcut customizations.

[image: Image]



Hth

David.P


			
			
													
					Last edited by David.P on Thu May 03, 2018 1:05 pm, edited 1 time in total.
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			Hi David,



Many thanks for the great suggestion!



Regards,

Stefan
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			@Davip.P



That is not an acceptable solution.



By telling me to spend all the time redoing all the configurations, Tracker Software is basically telling me that my time is worthless.


			
			
									
																
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								TrackerSupp-Daniel
							

							Site Admin
	Posts: 8515
	Joined: Wed Jan 03, 2018 6:52 pm



		
						

						
						Re: How to import settings in V7?
		


														
							
								Quote
							
						


							
						
									
						Post
					
								by TrackerSupp-Daniel » Thu May 03, 2018 4:39 pm
			

			
			
			
			Hello Pedro,

It is not that we think your time is worthless, It is instead that we found our developers time is better spent fixing existing bugs and working the new features that are needed by all to function in todays constantly evolving world.

This is an excerpt from our lead UI Developer in the thread you referenced earlier.


Vasyl-Tracker Dev Team wrote:Hi All.



We are sorry that you lost your toolbar customization when you moved from V6 to V7 and we appreciate that it must have been a frustrating experience for you. The development team discussed this issue at length and ultimately decided that we would not support V6 customization in V7.  The main reason for this is because there is a significant difference in the coding that implements the customization features between the two versions. Additionally, the customization data is stored differently in V7, in comparison to V6, which further complicates the issue and makes any kind of ‘auto-import mechanism’ impossible. We are always striving to improve our products, and the old method of customization that was used in V6 had a couple of fundamental issues that had to be addressed. It was not possible to fix these issues without changing the manner in which customization data is stored, which in turn meant editing a significant portion of the corresponding code – and this process had the unfortunate side-effect of toolbar customization from V6 losing its compatibility with V7.

However, we can guarantee you that, from this version forwards, the current manner in which toolbars are customized will always be supported – as we have now resolved some long-standing issues and we are satisfied that the current system is optimal. Therefore it will not be necessary to make such significant changes again, and you can rest assured that your customized toolbars will always be compatible with the software moving forwards.



Thanks for your understanding and patience.



Best

Regards.



In this light, it has been clearly explained why we will not be supporting V6 to V7 UI customizations.

We apologize for the inconvenience, however with the changes we made in V7, we have ensured that these new customizations will be forward compatible for years to come.


			
			
									
													Dan McIntyre - Support Technician

Tracker Software Products (Canada) LTD

+++++++++++++++++++++++++++++++++++

Our Web site domain and email address has changed as of 26/10/2023.

https://www.pdf-xchange.com

Support@pdf-xchange.com
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			My issue is not with possibly wasting my time in the future, my issue is with wasting my time now. 

Which is exactly the effect that making me redo all the configurations will have. 



Since I still have access to the old version that I had for personal use, I will not be upgrading. 

And from now on, I will recommend to all my colleagues and request to my employer that we stop using PDF XChange and move our company to a different product.
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			Hello Pedro,



We apologize for the inconvenience. As Vasyl explained there were bugs in the V6 customization and, try as we had, we simply are incapable of making the customization 100% compatible. It is unfortunate indeed that the time must be taken to redo the customization in V7. I have conferred with Vasyl and we agree with you that the need for this is quickly diminishing. Even if we were to spend weeks of development time on this, we will still be unable to make the customization totally compatible. In light of this, I would like to ease your frustrations.  If you are willing, please send me your V6 settings and I will do my best to approximate the same settings in V7 for you.  We really do care about each and every user, and I do hope that you will find this helpful.



Sincerely,


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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			Patrick-Tracker Supp wrote:In light of this, I would like to ease your frustrations.  If you are willing, please send me your V6 settings and I will do my best to approximate the same settings in V7 for you.  We really do care about each and every user, and I do hope that you will find this helpful.


What an amazing support offer, of an amazing company.



[image: Image]
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			David.P wrote:What an amazing support offer, of an amazing company.



I totally agree on that.

Furthermore Tracker not only has an outstanding support it also has an outstanding product !



HaPe
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			 In light of this, I would like to ease your frustrations. If you are willing, please send me your V6 settings and I will do my best to approximate the same settings in V7 for you. We really do care about each and every user, and I do hope that you will find this helpful.


I was not expecting that offer. But I'll call your bluff: how can I send and get the file?

I have exported the 'PDFXChangeEditorSettings.xcs' file from V6, and uploaded it to OneDrive here.


			
			
									
																
						


		


				
						
				
				Top
			
					

		
		

	


				
		

			
				


																[image: User avatar]														

								Patrick-Tracker Supp
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			Hello Pedro, 

We do not bluff. Is this the customization you are looking for? This is what I get when I load your settings - It appears to be the default configuration:



[image: Image]



I am sure you have not bluffed yourself, so perhaps there was a corruption in transmission from one drive. I am going home as I will be late for dinner otherwise. In the meantime, Please go to Edit> Export settings within Editor V6, then save the settings file in a zip archive. You may post it as an attachment to the forums, or send it in an email to support@pdf-xchange.com. 



Furthermore, can you please specify if you are using the portable or installed Editor?


			
			
									
													If posting files to this forum, you must archive the files to a ZIP, RAR or 7z file or they will not be uploaded.

Thank you.



Cheers,



Patrick Charest

Tracker Support North America
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			I am using the installed version. I exported the file by using the Edit > Export Settings. It is not the default settings. 

It should look like this:

			
					[image: Snipaste_2018-05-03_22-10-55.png]


		
		
		
			


I had selected only to export 'Program Options", but now I have selected "additional plugin data" and "history" as well. That might be the issue.

I attached a zip file with the data.
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					 PDFXChangeEditorSettings.zip
	(78.06 KiB) Downloaded 170 times
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			Hello Pedro,



Please try the attached file in the V7 Editor.

I hope I've transferred all of your settings. I also customized the styles for the tools that you have on the toolbars, but if I have missed some styles - please excuse me!



Regards,

Stefan
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					 PDFXChangeEditor_V7_Settings.zip
	(131.85 KiB) Downloaded 159 times
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						Re: How to import settings in V7?
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								by pedro henrique garcia » Fri May 04, 2018 1:09 pm
			

			
			
			
			That actually solves most of my problem. 

Hopefully there will be no unimportable changes in future versions of PDF XChange. 

It is actually the best PDF tool IMHO, but breaking a customer workflow is something that should never be done. 



Thanks.
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						Re: How to import settings in V7?
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								by Tracker Supp-Stefan » Fri May 04, 2018 1:22 pm
			

			
			
			
			Hello Pedro,



Glad we managed to assist!

We do appreciate that breaking the workflow is not nice, but due to the significant interface changes direct compatibility was impossible, and we decided to release the new V7 sooner rather than spend another month on this particular feature.



Regards,

Stefan
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						Re: How to import settings in V7?
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								by David.P » Sat Oct 06, 2018 8:29 pm
			

			
			
			
			Guys, seriously? Have you changed the settings format again? 



With the latest build 327, I can no longer import the settings I exported a few days ago with build 326.



Please tell me that this is not a feature but a bug   [image: :cry:]   [image: :oops:]
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								by Sasha - Tracker Dev Team » Mon Oct 08, 2018 7:44 am
			

			
			
			
			Hello David,



We will investigate this right now - can you please tell us what settings exactly should we try to reproduce this?



Cheers,

Alex
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https://www.youtube.com/channel/UC-TwAMNi1haxJ1FX3LvB4CQ
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								by David.P » Mon Oct 08, 2018 7:54 am
			

			
			
			
			Hello Alex, thanks for your fast reply.



When I tried to import the settings of build 326 into build 327 (on a fresh Windows 10 installation), it wouldn't offer to import any program settings, only things like stamps and history.



I then uninstalled build 327, temporarily installed build 326, re-imported the complete settings into build 326, and then installed 327 over it.



I tried it a couple of times, but build 327 was never able to import the program settings of build 326 on any machine.



I hope that helps to track the issue down



Cheers

David
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			Hello David,



Just spoke with our lead dev - he said that is issue is already known and will be fixed in the next quick release 327.1.



Cheers,

Alex
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